Back to overview
Resolved
Hosted Website Availability Issue
Jun 10, 2026 at 4:08am UTC
Affected services
health.servbase.site/health
Resolved
Jun 10, 2026 at 4:08am UTC
Summary:
On June 10, 2026, some Servbase hosted websites experienced availability issues and may have shown Cloudflare 520 errors.
Impact:
Some hosted websites may have been temporarily unavailable or intermittently unreachable during the incident window. This affected website access through the Servbase hosting layer.
Timeline:
- 2026-06-10 04:08 UTC: Earliest confirmed indication of the issue from available logs.
- 2026-06-10 09:21 UTC: Affected website access returned Cloudflare 520 errors.
- 2026-06-10 09:35 UTC: Corrective actions were applied.
- After corrective action: Hosted sites recovered.
Affected services